
<!doctype html>
<html lang="en-US">

<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="http://gmpg.org/xfn/11">
	
<link rel="apple-touch-icon" sizes="57x57" href="https://www.ere.net/wp-content/themes/ere/assets/favicons/apple-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="https://www.ere.net/wp-content/themes/ere/assets/favicons/apple-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="https://www.ere.net/wp-content/themes/ere/assets/favicons/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="https://www.ere.net/wp-content/themes/ere/assets/favicons/apple-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="https://www.ere.net/wp-content/themes/ere/assets/favicons/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="https://www.ere.net/wp-content/themes/ere/assets/favicons/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="https://www.ere.net/wp-content/themes/ere/assets/favicons/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="https://www.ere.net/wp-content/themes/ere/assets/favicons/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="https://www.ere.net/wp-content/themes/ere/assets/favicons/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192"  href="https://www.ere.net/wp-content/themes/ere/assets/favicons/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="32x32" href="https://www.ere.net/wp-content/themes/ere/assets/favicons/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://www.ere.net/wp-content/themes/ere/assets/favicons/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://www.ere.net/wp-content/themes/ere/assets/favicons/favicon-16x16.png">
<meta name="msapplication-TileColor" content="#ffffff">
<meta name="msapplication-TileImage" content="https://www.ere.net/wp-content/themes/ere/ms-icon-144x144.png">
<meta name="theme-color" content="#ffffff">
<meta charset="UTF-8" />
<meta name="viewport" content="user-scalable=no, width=device-width, initial-scale=1, maximum-scale=1">
<meta name="format-detection" content="telephone=no">
<meta name="format-detection" content="address=no">
<meta name="msapplication-TileColor" content="#ffffff">
<meta name="theme-color" content="#ffffff">
	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

   <!-- Cookie Consent -->
   <script>
   window.addEventListener( "load", function() {
      window.cookieconsent.initialise( {
         "content": {
            "dismiss": "OK",
            "href": "https://www.eremedia.com/privacy-policy",
            "message": "Our website uses cookies to improve your experience. "
         },
         "palette": {
            "popup": {
               "background": "hsl(233, 3%, 30%)"
            }
         },
         onPopupClose: function() {
            // Visitor has dismissed the notice
            // Track it in Google Tag Manager
            dataLayer.push({'event': 'cookieconsent_dismiss'});
         }
      } );
   } );
   </script>
   <!-- End Cookie Consent -->

   
<!-- Social Warfare v4.3.0 https://warfareplugins.com - BEGINNING OF OUTPUT -->
<meta property="og:description" content="As the leader of Talent Board and the Candidate Experience Awards, I’m often asked about the evolution of the candidate experience. What has changed in the decade that my organization has researched these experiences? What’s new and fresh? Frankly, I could answer these questions any number of ways. I could talk about the succession of recruiting technologies that have streamlined candidate experiences over the years. Or how the application process alone has undergone a series of transformative shifts. Or the ebb and flow of candidate resentment over the past decade and the forces driving it. Or how the “power” in"><meta property="og:title" content="What’s New and Fresh in the Candidate Experience? Absolutely Nothing"><meta property="article_author" content="vadim"><meta property="article_publisher" content="vadim"><meta name='image' property='og:image' content='https://www.ere.net/wp-content/uploads/sites/2/2022/07/bigstock-The-word-New-in-white-letters-22672391-e1657667924937.jpg'><meta property="fb:app_id" content="529576650555031"><meta property="og:type" content="article"><meta property="og:url" content="https://www.ere.net/whats-new-and-fresh-in-the-candidate-experience-absolutely-nothing/"><meta property="og:site_name" content="ERE"><meta property="article:published_time" content="2022-07-13T08:00:27-04:00"><meta property="article:modified_time" content="2022-07-12T20:36:36-04:00"><meta property="og:updated_time" content="2022-07-12T20:36:36-04:00"><meta name="twitter:title" content=""><meta name="twitter:description" content=""><meta name="twitter:image" content=""><meta name="twitter:creator" content=""><meta name="twitter:card" content="summary"><style>
	@font-face {
		font-family: "sw-icon-font";
		src:url("https://www.ere.net/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.eot?ver=4.3.0");
		src:url("https://www.ere.net/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.eot?ver=4.3.0#iefix") format("embedded-opentype"),
		url("https://www.ere.net/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.woff?ver=4.3.0") format("woff"),
		url("https://www.ere.net/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.ttf?ver=4.3.0") format("truetype"),
		url("https://www.ere.net/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.svg?ver=4.3.0#1445203416") format("svg");
		font-weight: normal;
		font-style: normal;
		font-display:block;
	}
</style>
<!-- Social Warfare v4.3.0 https://warfareplugins.com - END OF OUTPUT -->


	<!-- This site is optimized with the Yoast SEO plugin v17.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>What’s New and Fresh in the Candidate Experience? Absolutely Nothing &#8211; ERE</title>
	<link rel="canonical" href="https://www.ere.net/whats-new-and-fresh-in-the-candidate-experience-absolutely-nothing/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="What’s New and Fresh in the Candidate Experience? Absolutely Nothing - ERE" />
	<meta property="og:description" content="As the leader of Talent Board and the Candidate Experience Awards, I’m often asked about the evolution of the candidate experience. What has changed in the decade that my organization has researched these experiences? What’s new and fresh? Frankly, I could answer these questions any number of ways. I could talk about the succession of…" />
	<meta property="og:site_name" content="ERE" />
	<meta property="article:publisher" content="https://www.facebook.com/eremedia" />
	<meta property="article:published_time" content="2022-07-13T12:00:27+00:00" />
	<meta property="article:modified_time" content="2022-07-13T00:36:36+00:00" />
	<meta property="og:image" content="https://www.ere.net/wp-content/uploads/sites/2/2022/07/bigstock-The-word-New-in-white-letters-22672391-e1657667924937.jpg" />
	<meta property="og:image:width" content="900" />
	<meta property="og:image:height" content="506" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@ERE_net" />
	<meta name="twitter:site" content="@ERE_net" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="vadim" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="8 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.ere.net/#website","url":"https://www.ere.net/","name":"ERE","description":"The Industry Leader in Recruiting News and Insights","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.ere.net/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.ere.net/whats-new-and-fresh-in-the-candidate-experience-absolutely-nothing/#primaryimage","inLanguage":"en-US","url":"https://www.ere.net/wp-content/uploads/sites/2/2022/07/bigstock-The-word-New-in-white-letters-22672391-e1657667924937.jpg","contentUrl":"https://www.ere.net/wp-content/uploads/sites/2/2022/07/bigstock-The-word-New-in-white-letters-22672391-e1657667924937.jpg","width":900,"height":506},{"@type":"WebPage","@id":"https://www.ere.net/whats-new-and-fresh-in-the-candidate-experience-absolutely-nothing/#webpage","url":"https://www.ere.net/whats-new-and-fresh-in-the-candidate-experience-absolutely-nothing/","name":"What\u2019s New and Fresh in the Candidate Experience? Absolutely Nothing - ERE","isPartOf":{"@id":"https://www.ere.net/#website"},"primaryImageOfPage":{"@id":"https://www.ere.net/whats-new-and-fresh-in-the-candidate-experience-absolutely-nothing/#primaryimage"},"datePublished":"2022-07-13T12:00:27+00:00","dateModified":"2022-07-13T00:36:36+00:00","author":{"@id":"https://www.ere.net/#/schema/person/86fdee35aae06c6ffa56e182bd820acd"},"breadcrumb":{"@id":"https://www.ere.net/whats-new-and-fresh-in-the-candidate-experience-absolutely-nothing/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.ere.net/whats-new-and-fresh-in-the-candidate-experience-absolutely-nothing/"]}]},{"@type":"BreadcrumbList","@id":"https://www.ere.net/whats-new-and-fresh-in-the-candidate-experience-absolutely-nothing/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.ere.net/"},{"@type":"ListItem","position":2,"name":"Articles","item":"https://www.ere.net/articles/"},{"@type":"ListItem","position":3,"name":"What\u2019s New and Fresh in the Candidate Experience? Absolutely Nothing"}]},{"@type":"Person","@id":"https://www.ere.net/#/schema/person/86fdee35aae06c6ffa56e182bd820acd","name":"vadim","image":{"@type":"ImageObject","@id":"https://www.ere.net/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/c8f2dfe6cb05d8b1f9a6e7445228e695?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/c8f2dfe6cb05d8b1f9a6e7445228e695?s=96&d=mm&r=g","caption":"vadim"},"url":"https://www.ere.net/author/vadim/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//js.hs-scripts.com' />
<link rel='dns-prefetch' href='//www.formstack.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="ERE &raquo; Feed" href="https://www.ere.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="ERE &raquo; Comments Feed" href="https://www.ere.net/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="ERE &raquo; What’s New and Fresh in the Candidate Experience? Absolutely Nothing Comments Feed" href="https://www.ere.net/whats-new-and-fresh-in-the-candidate-experience-absolutely-nothing/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.ere.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='social-warfare-block-css-css'  href='https://www.ere.net/wp-content/plugins/social-warfare/assets/js/post-editor/dist/blocks.style.build.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.ere.net/wp-includes/css/dist/block-library/style.min.css?ver=5.9.3' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='ere-cookie-consent-styles-css'  href='https://www.ere.net/wp-content/plugins/eremedia-cookie-consent/css/cookieconsent.min.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='formstack-css-css'  href='//www.formstack.com/forms/css/2/wordpress-post.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='social_warfare-css'  href='https://www.ere.net/wp-content/plugins/social-warfare/assets/css/style.min.css?ver=4.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='e1e-style-css'  href='https://www.ere.net/wp-content/themes/ere/style.min.css?ver=1.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpmu-wpmu-ui-3-min-css-css'  href='https://www.ere.net/wp-content/plugins/wordpress-popup/inc/external/wpmu-lib/css/wpmu-ui.3.min.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='wpmu-animate-3-min-css-css'  href='https://www.ere.net/wp-content/plugins/wordpress-popup/inc/external/wpmu-lib/css/animate.3.min.css?ver=5.9.3' type='text/css' media='all' />
<script type='text/javascript' src='https://www.ere.net/wp-content/plugins/eremedia-cookie-consent/js/cookieconsent.min.js?ver=5.9.3' id='ere-cookie-consent-js'></script>
<script type='text/javascript' src='https://www.ere.net/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.ere.net/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.ere.net/wp-content/plugins/svg-support/js/min/svgs-inline-min.js?ver=1.0.0' id='bodhi_svg_inline-js'></script>
<script type='text/javascript' id='bodhi_svg_inline-js-after'>
cssTarget={"Bodhi":"img.style-svg","ForceInlineSVG":"style-svg"};ForceInlineSVGActive="true";
</script>
<link rel="https://api.w.org/" href="https://www.ere.net/wp-json/" /><link rel="alternate" type="application/json" href="https://www.ere.net/wp-json/wp/v2/posts/179537" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ere.net/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ere.net/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.ere.net/?p=179537' />
<link rel="alternate" type="application/json+oembed" href="https://www.ere.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ere.net%2Fwhats-new-and-fresh-in-the-candidate-experience-absolutely-nothing%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ere.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ere.net%2Fwhats-new-and-fresh-in-the-candidate-experience-absolutely-nothing%2F&#038;format=xml" />
			<!-- DO NOT COPY THIS SNIPPET! Start of Page Analytics Tracking for HubSpot WordPress plugin v8.4.90-->
			<script type="text/javascript">
				var _hsq = _hsq || [];
				_hsq.push(["setContentType", "blog-post"]);
			</script>
			<!-- DO NOT COPY THIS SNIPPET! End of Page Analytics Tracking for HubSpot WordPress plugin -->
						<script>
				(function() {
					var hbspt = window.hbspt = window.hbspt || {};
					hbspt.forms = hbspt.forms || {};
					hbspt._wpFormsQueue = [];
					hbspt.enqueueForm = function(formDef) {
						if (hbspt.forms && hbspt.forms.create) {
							hbspt.forms.create(formDef);
						} else {
							hbspt._wpFormsQueue.push(formDef);
						}
					}
					if (!window.hbspt.forms.create) {
						Object.defineProperty(window.hbspt.forms, 'create', {
							configurable: true,
							get: function() {
								return hbspt._wpCreateForm;
							},
							set: function(value) {
								hbspt._wpCreateForm = value;
								while (hbspt._wpFormsQueue.length) {
									var formDef = hbspt._wpFormsQueue.shift();
									if (!document.currentScript) {
										var formScriptId = 'leadin-forms-v2-js';
										hubspot.utils.currentScript = document.getElementById(formScriptId);
									}
									hbspt._wpCreateForm.call(hbspt.forms, formDef);
								}
							},
						});
					}
				})();
			</script>
			<link href="https://fonts.googleapis.com/css?family=Source+Sans+Pro:400,400i,600,600i,700,700i" rel="stylesheet">
	      <meta name="onesignal" content="wordpress-plugin"/>
            <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://www.ere.net");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'd3c645ae-52e4-4a2f-a19a-1d5f8c7d3aed';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.ere.net/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.4924b4f0-134c-425c-876d-dc71d8371c02";
oneSignal_options['persistNotification'] = false;
oneSignal_options['promptOptions'] = { };
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>

<!-- Google Ad Manager -->
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
	var googletag = googletag || {};
	googletag.cmd = googletag.cmd || [];
</script>

<script>
	googletag.cmd.push( function() {

		// Leaderboard
		var sizeLeaderboard = googletag.sizeMapping().
		addSize([1024, 480], [[728, 90],[970, 250],[970, 415]]).  //desktop
		addSize([0, 0], [320, 100]).  //mobile
		build();

		// In-article
		var sizeInArticle = googletag.sizeMapping().
		addSize([1024, 480], [640, 360]). //desktop
		addSize([0, 0], [300, 250]). //mobile
		build();

		// HP midpage
		var sizeMidPage = googletag.sizeMapping().
		addSize([1024, 480], [[970, 250]]).  //desktop
		addSize([0, 0], [[300, 250]]).   //mobile
		build();

		// Full-width
		var sizeFull = googletag.sizeMapping().
		addSize([1024, 480], [[970, 600]]).  //desktop
		addSize([0, 0], [320, 50]).  //mobile
		build();

		// Pop-ups
		var mapping5 = googletag.sizeMapping().
		addSize([1024, 480], [640, 480]). //desktop
		addSize([0, 480], [320, 480]). // mobile
		addSize([0,0], []). // no ad
		build();

		googletag.defineSlot('/3857430/New_HP_Leaderboard', [[320, 100], [970, 415], [728, 90], [970, 250]], 'div-gpt-ad-1481832207821-0').defineSizeMapping(sizeLeaderboard).addService(googletag.pubads());

		googletag.defineSlot('/3857430/New_HP_MidPage', [[300, 250], [970, 250]], 'div-gpt-ad-1481833116260-0').defineSizeMapping(sizeMidPage).addService(googletag.pubads());

		googletag.defineSlot('/3857430/New_HP_HalfPage', [300, 600], 'div-gpt-ad-1481833349704-0').addService(googletag.pubads());

		googletag.defineSlot('/3857430/Article_Leaderboard_New', [[970, 415], [320, 100], [970, 250], [728, 90]], 'div-gpt-ad-1481833043790-0').defineSizeMapping(sizeLeaderboard).addService(googletag.pubads());

		googletag.defineSlot('/3857430/New_Article_HalfPage', [300, 600], 'div-gpt-ad-1481833730344-0').addService(googletag.pubads());

		googletag.defineSlot('/3857430/New_Article_InArticle', [[640, 360], [300, 250]], 'div-gpt-ad-1481833841864-0').defineSizeMapping(sizeInArticle).addService(googletag.pubads());

		googletag.defineSlot('/3857430/New_InArticle_FullWidth', [[320, 50], [970, 600]], 'div-gpt-ad-1481833931106-0').defineSizeMapping(sizeFull).addService(googletag.pubads());

		googletag.defineSlot('/3857430/New_Article_RightMPU', [300, 250], 'div-gpt-ad-1481833349704-5').addService(googletag.pubads());

		googletag.pubads().collapseEmptyDivs();

		googletag.pubads().setTargeting( 'Brand', [ 'ere' ] );

		googletag.enableServices();
	});
</script>
<!-- End Google Ad Manager -->

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-TJD55K');</script>
<!-- End Google Tag Manager -->
</head>

<body class="post-template-default single single-post postid-179537 single-format-standard" itemscope itemtype="https://schema.org/WebPage">


<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TJD55K"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

<div id="site" class="site">

	
	<section id="masthead" class="masthead" role="banner">
		<div class="wrap">
			
<div class="branding">
	<a href="https://www.ere.net/" rel="home" title="ERE">
		<img src="https://www.ere.net/wp-content/uploads/sites/2/2018/10/logo-ere-white.svg" class="logo" alt="ERE logo white" loading="lazy" />		<p class="site-title">ERE</p>
					<p class="site-subtitle">Recruiting Intelligence</p>
			</a>
</div><!-- .branding -->


<nav id="site-nav" class="site-nav">

	
	<button class="site-menu__button" data-popup="button" aria-controls="site-menu__container" title="Menu">
		<svg class="icon-menu" viewBox="0 0 28 22" xmlns="http://www.w3.org/2000/svg"><rect y="18" width="28" height="4"/><rect y="9" width="28" height="4"/><rect width="28" height="4"/></svg>		<span>Menu</span>
	</button>

	<div id="site-menu__container" class="popup" data-popup="popup">
		<button class="popup__button" data-popup="button" aria-controls="site-menu__container" title="Close">
			<svg class="icon-close" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><g fill="#fff"><rect transform="rotate(-45 12 12)" x="-2" y="10" width="28" height="4"/><rect transform="rotate(45 12 12)" x="-2" y="10" width="28" height="4"/></g></svg>			<span>Close</span>
		</button>
		<ul id="site-menu" class="site-menu"><li id="menu-item-122910" class="menu-item--home menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-122910"><a href="https://www.ere.net/">Home</a></li>
<li id="menu-item-128053" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-128053"><a href="https://www.ere.net/subscribe/">Subscribe</a></li>
<li id="menu-item-122018" class="menu-item--conferences menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-122018"><a>Conferences</a>
<ul class="sub-menu">
	<li id="menu-item-122911" class="menu-title menu-title--ere menu-item menu-item-type-custom menu-item-object-custom menu-item-122911"><a target="_blank" rel="noopener" href="https://www.ererecruitingconference.com/">ERE Recruiting Conference</a></li>
	<li id="menu-item-122912" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122912"><a target="_blank" rel="noopener" href="https://www.ererecruitingconference.com/">ERE Recruiting Conference</a></li>
	<li id="menu-item-122913" class="menu-title menu-title--sourcecon menu-item menu-item-type-custom menu-item-object-custom menu-item-122913"><a target="_blank" rel="noopener" href="https://conference.sourcecon.com/">SourceCon</a></li>
	<li id="menu-item-122915" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122915"><a target="_blank" rel="noopener" href="https://conference.sourcecon.com/">SourceCon</a></li>
	<li id="menu-item-122916" class="menu-title menu-title--talent42 menu-item menu-item-type-custom menu-item-object-custom menu-item-122916"><a target="_blank" rel="noopener" href="https://www.talent42.com">Talent42</a></li>
	<li id="menu-item-122917" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122917"><a target="_blank" rel="noopener" href="https://www.talent42.com">Talent42</a></li>
</ul>
</li>
<li id="menu-item-122017" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122017"><a target="_blank" rel="noopener" href="https://www.eretraining.com/">Training</a></li>
<li id="menu-item-122019" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122019"><a href="https://www.eremedia.com/webinars/">Webinars</a></li>
<li id="menu-item-124603" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-124603"><a href="https://www.tlnt.com/reports">Research</a></li>
<li id="menu-item-122021" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122021"><a target="_blank" rel="noopener" href="https://www.recruitingjobs.com/">Jobs</a></li>
</ul>	</div>

</nav><!-- #site-nav -->
		</div><!-- .wrap -->
	</section><!-- #masthead -->

	
<section class="section--ad-top">
	
<div class="ad ad--top" id="div-gpt-ad-1481832207821-0">
	 <script>
		 googletag.cmd.push(function() { googletag.display('div-gpt-ad-1481832207821-0'); });
	 </script>

	 </div><!-- .ad -->
</section><!-- .section -->
<div class="main-aside-wrap">
<main id="site-main" class="site-main" role="main" itemscope itemtype="http://schema.org/Blog" itemprop="mainContentOfPage">
	<div class="wrap">

		
<article class="type-post format-standard hentry category-candidate-control-management category-candidate-engagement category-candidate-experience category-closing category-hr-news category-interviewing category-offers tag-featured data-tech-research data-tech-state-of-talent-acquisition" itemscope itemtype="http://schema.org/BlogPosting" itemprop="blogPost">

			<header class="entry-header">
			<h1 class="entry-title" itemprop="headline">What’s New and Fresh in the Candidate Experience? Absolutely Nothing</h1><p class="entry-meta"><span class="entry-author" itemprop="author" itemscope itemtype="http://schema.org/Person">By <a href="https://www.ere.net/author/kevin-grossman/" title="Posts by Kevin Grossman" class="author url fn" rel="author">Kevin Grossman</a></span><time class="entry-date published" datetime="2022-07-13T08:00:27-04:00" itemprop="datePublished">July 13, 2022</time><time class="updated" datetime="2022-07-12T20:36:36-04:00">July 12, 2022</time></p><div class="swp_social_panel swp_horizontal_panel swp_flat_fresh  swp_default_full_color swp_other_full_color swp_individual_full_color scale-100 scale-full_width" data-min-width="" data-float-color="" data-float="top" data-float-mobile="bottom" data-transition="slide" data-post-id="179537" ><div class="nc_tweetContainer swp_share_button swp_twitter" data-network="twitter"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://twitter.com/intent/tweet?text=What%E2%80%99s+New+and+Fresh+in+the+Candidate+Experience%3F+Absolutely+Nothing&url=https%3A%2F%2Fwww.ere.net%2Fwhats-new-and-fresh-in-the-candidate-experience-absolutely-nothing%2F" data-link="https://twitter.com/intent/tweet?text=What%E2%80%99s+New+and+Fresh+in+the+Candidate+Experience%3F+Absolutely+Nothing&url=https%3A%2F%2Fwww.ere.net%2Fwhats-new-and-fresh-in-the-candidate-experience-absolutely-nothing%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_twitter_icon"></i><span class="swp_share">Tweet</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_facebook" data-network="facebook"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.ere.net%2Fwhats-new-and-fresh-in-the-candidate-experience-absolutely-nothing%2F" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.ere.net%2Fwhats-new-and-fresh-in-the-candidate-experience-absolutely-nothing%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_facebook_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_linkedin" data-network="linkedin"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.ere.net%2Fwhats-new-and-fresh-in-the-candidate-experience-absolutely-nothing%2F" data-link="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.ere.net%2Fwhats-new-and-fresh-in-the-candidate-experience-absolutely-nothing%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_linkedin_icon"></i><span class="swp_share">Share</span></span></span></span></a></div></div>		</header>
	
			<figure class="entry-image">
			<img width="700" height="467" src="https://www.ere.net/wp-content/uploads/sites/2/2022/07/bigstock-The-word-New-in-white-letters-22672391-e1657667924937-700x467.jpg" class="attachment-large-thumbnail size-large-thumbnail wp-post-image" alt="" srcset="https://www.ere.net/wp-content/uploads/sites/2/2022/07/bigstock-The-word-New-in-white-letters-22672391-e1657667924937-700x467.jpg 700w, https://www.ere.net/wp-content/uploads/sites/2/2022/07/bigstock-The-word-New-in-white-letters-22672391-e1657667924937-400x266.jpg 400w" sizes="(max-width: 700px) 100vw, 700px" />					</figure>
	
	
			<div class="entry-content" itemprop="text">
			<p><span style="font-weight: 400">As the leader of Talent Board and the Candidate Experience Awards, I’m often asked about the evolution of the candidate experience. What has changed in the decade that my organization has researched these experiences? What’s new and fresh?</span></p>
<p><span style="font-weight: 400">Frankly, I could answer these questions any number of ways. I could talk about the succession of recruiting technologies that have streamlined candidate experiences over the years. Or how the application process alone has undergone a series of transformative shifts. Or the ebb and flow of candidate resentment over the past decade and the forces driving it. Or how the “power” in the jobs market has shifted from employers to job seekers and what that means to the candidate experience.</span></p>
<p><span style="font-weight: 400">I could also talk about how in the early returns from our </span><a href="https://www.thetalentboard.org/benchmark-research/how-to-register/" target="_blank" rel="noopener"><span style="font-weight: 400">2022 candidate experience benchmark research program</span></a><span style="font-weight: 400">, candidate resentment is down 29% from 2021, and candidates’ willingness to refer is up 10% from last year. That’s definitely a positive trend, and we’ll see where it all ends up when the program closes August 31 and we begin our complete review of all this year’s data.  </span></p>
<p><span style="font-weight: 400">As I said, I could reply in many different ways. But I usually answer by saying that what’s new and fresh in the candidate experience is…absolutely nothing.</span></p>
<p><span style="font-weight: 400">That might sound glib, but I’m actually trying to be helpful. I’ve found that people who ask what’s new in the candidate experience typically don’t want a history lesson. What they really want is to know what’s happening </span><i><span style="font-weight: 400">today</span></i><span style="font-weight: 400">. More specifically, they want to know which recruiting tools, strategies, and best practices support the most successful candidate experiences right now. They’re interested in learning how to differentiate their company in today’s fiercely competitive talent market and how to better engage qualified candidates.</span></p>
<p><span style="font-weight: 400">That’s why my “absolutely nothing” response isn’t as silly as it might seem. It cuts right to the heart of this basic fact: The qualities that made up a great candidate experience a decade ago </span><i><span style="font-weight: 400">still</span></i><span style="font-weight: 400"> make up a great experience today. And job seekers continue to crave these qualities from potential employers:</span></p>
<ol>
<li style="font-weight: 400"><span style="font-weight: 400">Frequent and respectful communication</span></li>
<li style="font-weight: 400"><span style="font-weight: 400">Insights into your company and its culture</span></li>
<li style="font-weight: 400"><span style="font-weight: 400">Plenty of feedback</span></li>
</ol>
<h2><b>1. Frequent and Respectful Communication</b></h2>
<p><span style="font-weight: 400">Each phase of the candidate experience offers employers critical communication touchpoints: pre- and post-application, for example; before and after interviews, screenings, and evaluations; even during the job-offer phase, where poor communication can still cost you a great candidate. </span></p>
<p><span style="font-weight: 400">Employers that take advantage of as many of these touchpoints as possible — letting candidates know where they stand and what’s next every step of the way — are going to be the real winners in the competition for talent because they’re offering the kind of respectful experience that candidates are eager to return to again and again, </span><i><span style="font-weight: 400">even after they’ve been rejected for a particular job</span></i><span style="font-weight: 400">.</span></p>
<p><span style="font-weight: 400">Now that talent shortages are a real concern for so many employers, recruiting teams are raising their communications game, taking steps to be more informative and responsive across the entire candidate experience. They’re using chatbots and more advanced conversational AI tools, text messaging, employer branding and marketing campaigns, and good old-fashioned emails and phone calls to keep candidates engaged. And they’re communicating through an extensive array of channels and platforms, including job boards and specialized talent communities, LinkedIn and other social media, and their own careers sites and employer marketing materials.</span></p>
<p><span style="font-weight: 400">This surge in candidate communication is a welcome sign. Just a few years ago, many employers were getting away with less-than-stellar (if not downright poor) communication. Candidates would apply to jobs and never hear back. Others would email or call recruiters and still not receive a response. Others, lucky enough to get a chance to interview, would end up being ghosted by recruiters or hiring managers when interview time rolled around.</span></p>
<p><span style="font-weight: 400">Some of these missteps are still occurring, of course, and they add up to one huge lost opportunity. In fact, Talent Board’s research shows that 11% of North American candidates voluntarily removed themselves from the recruiting process in 2020 because of poor communication. That’s literally hundreds of thousands of candidates whom employers never had the chance to meet or assess. </span></p>
<p><span style="font-weight: 400">But the situation isn’t all bad. Back in 2017, Talent Board’s research revealed that more than half (52%) of all North American candidates were still waiting to hear back from employers </span><i><span style="font-weight: 400">more than two months after</span></i><span style="font-weight: 400"> applying to a job. In 2021, this percentage had been substantially reduced to 23%, a welcome improvement.</span></p>
<p><span style="font-weight: 400">As with so many aspects of the candidate experience, there’s no formula for great communication — but great communication is a hallmark of every great candidate experience.</span></p>
<h2><b>2. Insights Into Your Company and Its Culture</b></h2>
<p><span style="font-weight: 400">Employers sometimes make the error of thinking that candidates only want to know about a job’s responsibilities and what it pays. That’s simply not the case.</span></p>
<p><span style="font-weight: 400">Talent Board’s research clearly shows that job responsibilities and compensation are just scratching the surface of what candidates want to know. </span></p>
<p><span style="font-weight: 400">For instance, 35% of North American candidates last year said that the most important content when they’re researching potential employers is related to company culture, and 26% said they wanted more information about diversity and inclusion initiatives. Our previous research also revealed that:</span></p>
<ul>
<li style="font-weight: 400"><span style="font-weight: 400">32% of candidates want to know why people want to work for a company</span></li>
<li style="font-weight: 400"><span style="font-weight: 400">27% want to know why employees stay with a company</span></li>
<li style="font-weight: 400"><span style="font-weight: 400">22% want to know a company’s values</span></li>
</ul>
<p><span style="font-weight: 400">Yes, candidates care about job responsibilities and compensation — a lot. But they also want deeper insights into the organizations they may be working at. This shouldn’t come as a surprise, given the fallout from Covid and the Great Resignation and their lasting impacts on the talent marketplace. </span></p>
<p><span style="font-weight: 400">As McKinsey &amp; Company partner Bryan Hancock stated in a recent </span><a href="https://chiefexecutive.net/special-report-the-new-laws-of-talent-attraction/" target="_blank" rel="noopener"><span style="font-weight: 400">article on ChiefExecutive.net</span></a><span style="font-weight: 400">, “Nearly two-thirds of U.S.-based employees have told us that Covid-19 has caused them to reexamine their individual purpose—what they’re doing in life and work and what they want to be doing in the future.” And a recent </span><a href="https://hbr.org/sponsored/2022/01/how-to-attract-top-talent-in-2022" target="_blank" rel="noopener"><i><span style="font-weight: 400">Harvard Business Review</span></i><span style="font-weight: 400"> article</span></a><span style="font-weight: 400"> pointed out that candidates today “are increasingly looking to join organizations that have a greater purpose beyond profitability.”</span></p>
<p><span style="font-weight: 400">Employers that want to effectively engage best-fit candidates (those who are closely aligned to the organization, its mission, and the jobs it offers) need to keep all of this in mind in their talent attraction initiatives. They must make clear to candidates exactly what their businesses are all about — that is, how their jobs lend meaning and purpose to employees’ lives, as well as the roles their employees play in helping to achieve a greater good.</span></p>
<div class="ad ad--in-post" id="div-gpt-ad-1481833841864-0">
	<h5 class="ad-title">Article Continues Below</h5>		<script>
			googletag.cmd.push(function() { googletag.display('div-gpt-ad-1481833841864-0'); });
		</script>
	</div>

<h2><b>3. Plenty of Feedback</b></h2>
<p><span style="font-weight: 400">As Talent Board’s research has shown again and again, giving candidates feedback and requesting it from them are hallmarks of the world’s highest-rated candidate experiences. The top 10 CandE Award-winning companies, for example, all provided feedback to candidates in 2021.</span></p>
<p><span style="font-weight: 400">Giving feedback helps candidates understand why they’re moving or not moving forward in the recruiting process. Constructive feedback actually raises candidates’ perception that they’ve been treated fairly even when they </span><i><span style="font-weight: 400">aren’t</span></i><span style="font-weight: 400"> moving forward. This, in turn, raises how positively they rate their experiences. </span></p>
<p><span style="font-weight: 400">The same is true of asking candidates for feedback about their experiences; it raises positive perceptions and subsequent ratings because candidates appreciate being made to feel that employers care about their opinions.</span></p>
<p><span style="font-weight: 400">Sadly, employers are missing out on key opportunities to give and receive candidate feedback across the recruiting process, and they’re missing out on a powerful set of benefits as a result. Here are some insights from our </span><a href="https://www.thetalentboard.org/benchmark-research/cande-research-reports/" target="_blank" rel="noopener"><span style="font-weight: 400">2020 and 2021 benchmark research</span></a><span style="font-weight: 400">:</span></p>
<p><b>Missed opportunities.</b><span style="font-weight: 400"> Only 2% of employers in North America bothered to ask candidates for feedback during the pre-application stage, and another 2% asked for feedback post-application (but prior to an interview). Gathering feedback at these crucial stages could help employers significantly improve their talent attraction efforts. </span></p>
<p><span style="font-weight: 400">Just 18% of employers asked candidates for post-interview feedback; and 60% of candidates received no feedback from employers after being rejected following a screening or interview. </span></p>
<p><span style="font-weight: 400">Most shocking of all, only 44% of employers asked for feedback </span><i><span style="font-weight: 400">after candidates had been hired</span></i><span style="font-weight: 400">, and 16% of employers never asked candidates for feedback </span><i><span style="font-weight: 400">at any stage of the recruiting process</span></i><span style="font-weight: 400">.</span></p>
<p><b>Giving feedback to candidates.</b><span style="font-weight: 400"> When employers gave candidates feedback at any point in the recruiting process in 2021, candidates’ willingness to refer others increased nearly 25%, and their willingness to increase their relationship with these employers (including applying to future jobs and purchasing their products and services) increased 36%.</span></p>
<p><b>Asking for feedback.</b><span style="font-weight: 400"> When candidates were asked for their feedback after the application process, they were 38% more likely to apply to future jobs with those companies. When they were asked for feedback following an interview, they were 74% more likely to refer others to those companies. And when candidates were asked for feedback at any point during the screening and interviewing stage, there was a 93% increase in their “great candidate experience” ratings.</span></p>
<p><span style="font-weight: 400">Historically, the quality of the candidate experience </span><i><span style="font-weight: 400">has</span></i><span style="font-weight: 400"> improved over the years Talent Board has been researching it. This improvement has come about for a number of reasons, including the sheer hard work and relentless dedication of recruiters and TA professionals. </span></p>
<p><span style="font-weight: 400">Recruiting technologies have also helped to streamline candidate experiences and make them more personalized, while reducing some of the legwork and heavy lifting for TA teams. But as many of the preceding data points make clear, there’s still plenty of room for improvement. </span></p>
<p><span style="font-weight: 400">I have a feeling, though, that no matter how things change or how much improvement is made in the next 10 years, those “old and stale” qualities that make up today’s great candidate experiences will still be around. And they’ll be as fresh and desirable as ever.</span></p>
<div class="swp_social_panel swp_horizontal_panel swp_flat_fresh  swp_default_full_color swp_other_full_color swp_individual_full_color scale-100 scale-full_width" data-min-width="" data-float-color="" data-float="top" data-float-mobile="bottom" data-transition="slide" data-post-id="179537" ><div class="nc_tweetContainer swp_share_button swp_twitter" data-network="twitter"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://twitter.com/intent/tweet?text=What%E2%80%99s+New+and+Fresh+in+the+Candidate+Experience%3F+Absolutely+Nothing&url=https%3A%2F%2Fwww.ere.net%2Fwhats-new-and-fresh-in-the-candidate-experience-absolutely-nothing%2F" data-link="https://twitter.com/intent/tweet?text=What%E2%80%99s+New+and+Fresh+in+the+Candidate+Experience%3F+Absolutely+Nothing&url=https%3A%2F%2Fwww.ere.net%2Fwhats-new-and-fresh-in-the-candidate-experience-absolutely-nothing%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_twitter_icon"></i><span class="swp_share">Tweet</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_facebook" data-network="facebook"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.ere.net%2Fwhats-new-and-fresh-in-the-candidate-experience-absolutely-nothing%2F" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.ere.net%2Fwhats-new-and-fresh-in-the-candidate-experience-absolutely-nothing%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_facebook_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_linkedin" data-network="linkedin"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.ere.net%2Fwhats-new-and-fresh-in-the-candidate-experience-absolutely-nothing%2F" data-link="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.ere.net%2Fwhats-new-and-fresh-in-the-candidate-experience-absolutely-nothing%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_linkedin_icon"></i><span class="swp_share">Share</span></span></span></span></a></div></div><div class="swp-content-locator"></div><!-- AI CONTENT END 2 -->
		</div><!-- .entry-content -->
	
</article>

<article class="author-bio">
	<figure class="author-image">
		<img width="96" height="96" src="https://www.ere.net/wp-content/uploads/sites/2/2014/07/KevinWGrossman_200518-150x150.jpeg" class="avatar avatar-96 photo wp-post-image" alt="" loading="lazy" srcset="https://www.ere.net/wp-content/uploads/sites/2/2014/07/KevinWGrossman_200518-150x150.jpeg 150w, https://www.ere.net/wp-content/uploads/sites/2/2014/07/KevinWGrossman_200518-300x300.jpeg 300w, https://www.ere.net/wp-content/uploads/sites/2/2014/07/KevinWGrossman_200518-1024x1024.jpeg 1024w, https://www.ere.net/wp-content/uploads/sites/2/2014/07/KevinWGrossman_200518-768x768.jpeg 768w, https://www.ere.net/wp-content/uploads/sites/2/2014/07/KevinWGrossman_200518-1536x1536.jpeg 1536w, https://www.ere.net/wp-content/uploads/sites/2/2014/07/KevinWGrossman_200518.jpeg 1782w" sizes="(max-width: 96px) 100vw, 96px" />	</figure>
	<h3 class="author-title">
		<a href="/author/kevin-grossman/" title="Posts by Kevin Grossman" class="" rel="author">Kevin Grossman</a>	</h3>
	<div class="author-content">
		<p>Kevin W. Grossman is the president of <a href="https://www.thetalentboard.org/" target="_blank" rel="noopener">Talent Board</a> and the Candidate Experience Awards. Founded in 2011, it’s the first nonprofit research organization focused on the elevation and promotion of a quality candidate experience with industry benchmarks that highlight accountability, fairness and business impact.</p>
<p>Kevin has over 22 years of domain expertise in the human resource and talent acquisition industry and related technology marketplace. He’s been a prolific industry writer since 2004. His first business book on career management, <em>Tech Job Hunt Handbook,</em> was released in December 2012 from Apress. His second book, <em>The Business Impact of Candidate Experience,</em> will be released in 2022 by Kogan Page.</p>
<p>Kevin holds a B.A. in psychology from San Jose State University, is an HCI certified Talent Acquisition Strategist (TAS) and Human Capital Strategist, and has learning certificates from eCornell on HR Analytics and Diversity and Inclusion.</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>LinkedIn</p>
<p><a href="https://www.linkedin.com/in/kevinwgrossman/">https://www.linkedin.com/in/kevinwgrossman/</a></p>
<p>&nbsp;</p>
<p>Twitter</p>
<p><a href="https://twitter.com/KevinWGrossman">https://twitter.com/KevinWGrossman</a></p>	</div>
	<a href="/author/kevin-grossman/" title="Posts by Kevin Grossman" class="author-nav" rel="author">Author Archive</a></article><!-- .author-bio -->

<section class="topics">
	<h3>Topics</h3>
	<div>
		<a href="https://www.ere.net/category/talent-acquisition/hiring-process/candidate-control-management/" rel="category tag">Candidate Control &amp; Management</a><!----><a href="https://www.ere.net/category/talent-acquisition/recruiting/candidate-engagement/" rel="category tag">Candidate Engagement</a><!----><a href="https://www.ere.net/category/talent-acquisition/recruiting/candidate-experience/" rel="category tag">Candidate Experience</a><!----><a href="https://www.ere.net/category/talent-acquisition/hiring-process/closing/" rel="category tag">Closing</a><!----><a href="https://www.ere.net/category/human-resources/hr-management/hr-news/" rel="category tag">HR News</a><!----><a href="https://www.ere.net/category/talent-acquisition/hiring-process/interviewing/" rel="category tag">Interviewing</a><!----><a href="https://www.ere.net/category/talent-acquisition/hiring-process/offers/" rel="category tag">Offers</a><a href="https://www.ere.net/data-tech/research/" rel="tag">Research</a><a href="https://www.ere.net/data-tech/state-of-talent-acquisition/" rel="tag">State of Talent Acquisition</a>	</div>
</section><!-- .topics -->

	</div><!-- .wrap -->
</main><!-- #site-main -->


<aside id="site-aside" class="site-aside" role="complementary" itemscope itemtype="http://schema.org/WPSideBar">
	<section id="p12a_popular_posts-4" class="widget widget--popular section section--entries"><div class="wrap"><h2 class="widget-title">Popular</h2><div class="entries list">
<article class="type-post format-standard hentry category-personal-productivity category-recruiting-ta-training category-training-learning-development tag-featured" itemscope itemtype="http://schema.org/BlogPosting" itemprop="blogPost">

			<header class="entry-header">
			<h3 class="entry-title" itemprop="headline"><a href="https://www.ere.net/what-nobody-told-me-when-i-started-recruiting/">‘What Nobody Told Me When I Started Recruiting’</a></h3>		</header>
	
	
	
	
</article>

<article class="type-post format-standard hentry category-culture category-employee-handbook-policies category-future-of-hr category-hr-news category-leadership category-productivity category-strategic-hr category-virtual-remote category-work-life-balance tag-featured tag-tesla series-covid-19-coverage" itemscope itemtype="http://schema.org/BlogPosting" itemprop="blogPost">

			<header class="entry-header">
			<h3 class="entry-title" itemprop="headline"><a href="https://www.ere.net/elon-musk-is-driving-talent-in-the-wrong-direction/">Elon Musk Is Driving Talent in the Wrong Direction</a></h3>		</header>
	
	
	
	
</article>

<article class="type-post format-standard hentry category-recruiting category-sourcing category-strategic-planning category-strategy category-talent-acquisition tag-featured" itemscope itemtype="http://schema.org/BlogPosting" itemprop="blogPost">

			<header class="entry-header">
			<h3 class="entry-title" itemprop="headline"><a href="https://www.ere.net/recruiting-pros-reveal-how-they-are-shifting-their-strategies/">Recruiting Pros Reveal How They Are Shifting Their Strategies</a></h3>		</header>
	
	
	
	
</article>

<article class="type-post format-standard hentry category-hiring-process category-retention-engagement category-stay-interviews tag-featured tag-quit-rate" itemscope itemtype="http://schema.org/BlogPosting" itemprop="blogPost">

			<header class="entry-header">
			<h3 class="entry-title" itemprop="headline"><a href="https://www.ere.net/the-employee-engagement-cliff-explains-why-many-new-hires-quit/">The Employee Engagement Cliff Explains Why Many New Hires Quit</a></h3>		</header>
	
	
	
	
</article>

<article class="type-post format-standard hentry category-corporate-career-website category-employer-branding category-job-postings tag-featured" itemscope itemtype="http://schema.org/BlogPosting" itemprop="blogPost">

			<header class="entry-header">
			<h3 class="entry-title" itemprop="headline"><a href="https://www.ere.net/the-best-way-to-craft-a-job-post-opening/">The Best Way to Craft a Job Post Opening</a></h3>		</header>
	
	
	
	
</article>
</div><!-- .entries --></div><!-- .wrap --></section><section id="p12a_webinars-3" class="widget widget--webinars"><div class="wrap"><h2 class="widget-title"><a href="https://www.eremedia.com/webinars">Upcoming Webinars</a></h2><div class="entries-webinars">
				<article class="type-ere_webinar hentry">

					<header class="entry-header">
						<h3 class="entry-title" itemprop="headline"><a href="https://www.eremedia.com/?p=122189">Rapid Wins in Recruitment Marketing &#8211; How to Ramp Up Fast and Get Results</a></h3>						<p class="entry-meta">
							<span class="webinar-date">July 13th</span>
															<span class="webinar-time">2 PM ET</span>
													</p>
					</header>

					<div class="webinar-more">
						<a href="https://www.eremedia.com/?p=122189">Learn More</a>					</div>

				</article>

			
				<article class="type-ere_webinar hentry">

					<header class="entry-header">
						<h3 class="entry-title" itemprop="headline"><a href="https://www.eremedia.com/?p=122237">How to Build an Employee Ambassador Program: A Fireside Chat With Leading Employer Brand Practitioners</a></h3>						<p class="entry-meta">
							<span class="webinar-date">July 14th</span>
															<span class="webinar-time">2 PM ET </span>
													</p>
					</header>

					<div class="webinar-more">
						<a href="https://www.eremedia.com/?p=122237">Learn More</a>					</div>

				</article>

			
				<article class="type-ere_webinar hentry">

					<header class="entry-header">
						<h3 class="entry-title" itemprop="headline"><a href="https://www.eremedia.com/?p=122255">The Story Planning Playbook for Recruitment Marketers and Employer Branders</a></h3>						<p class="entry-meta">
							<span class="webinar-date">July 21st</span>
															<span class="webinar-time">2 PM ET</span>
													</p>
					</header>

					<div class="webinar-more">
						<a href="https://www.eremedia.com/?p=122255">Learn More</a>					</div>

				</article>

			</div><!-- .entries-webinars --></div><!-- .wrap --></section></aside><!-- #site-aside -->
</div><!-- .site-inner -->
	<footer id="site-footer" class="site-footer" role="contentinfo" itemscope itemtype="http://schema.org/WPFooter">
		<div class="wrap">
			
<div class="branding">
	<a href="https://www.eremedia.com/" rel="home" title="ERE Media">
		<img src="https://www.ere.net/wp-content/uploads/2018/08/logo-eremedia-white.svg" class="logo" alt="ERE Media logo" loading="lazy" />		<p class="site-title">ERE Media</p>
			</a>
</div><!-- .branding -->

					<div class="footer-area">
						<section id="nav_menu-5" class="widget widget_nav_menu"><div class="menu-footer-menu-1-container"><ul id="menu-footer-menu-1" class="menu"><li id="menu-item-122024" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-122024"><a href="https://www.ere.net/">ERE</a></li>
<li id="menu-item-122025" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122025"><a href="https://www.sourcecon.com/">SourceCon</a></li>
<li id="menu-item-122026" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122026"><a href="https://www.tlnt.com/">TLNT</a></li>
</ul></div></section>					</div>
									<div class="footer-area">
						<section id="nav_menu-3" class="widget widget_nav_menu"><div class="menu-footer-menu-2-container"><ul id="menu-footer-menu-2" class="menu"><li id="menu-item-122027" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122027"><a href="https://www.eremedia.com/about/">About ERE Media</a></li>
<li id="menu-item-122028" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122028"><a href="https://www.eremedia.com/contact/">Contact</a></li>
<li id="menu-item-122029" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122029"><a href="https://www.eremedia.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-122030" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122030"><a href="https://www.eremedia.com/editorial-ethics/">Editorial Ethics</a></li>
</ul></div></section>					</div>
									<div class="footer-area">
						<section id="nav_menu-4" class="widget widget_nav_menu"><div class="menu-footer-menu-3-container"><ul id="menu-footer-menu-3" class="menu"><li id="menu-item-122031" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122031"><a href="https://www.eremedia.com/advertise/">Advertise</a></li>
<li id="menu-item-122032" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122032"><a href="https://www.eremedia.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-122033" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122033"><a href="https://www.eremedia.com/code-of-conduct/">Code of Conduct</a></li>
<li id="menu-item-122034" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122034"><a href="https://www.eremedia.com/foundation/">ERE Foundation</a></li>
</ul></div></section>					</div>
						</div>
	</footer><!-- #site-footer -->

	<section id="colophon" class="colophon">
		<div class="wrap">
								<div class="colophon-area">
						<section id="text-2" class="widget widget_text">			<div class="textwidget"><p>© 2020 ERE Media. All Rights Reserved.</p>
</div>
		</section>					</div>
						</div><!-- .wrap -->
	</section><!-- #colophon -->

</div><!-- #site -->
<script>window._popup_data = {"ajaxurl":"https:\/\/www.ere.net\/wp-admin\/admin-ajax.php","do":"get_data","ajax_data":{"orig_request_uri":"\/whats-new-and-fresh-in-the-candidate-experience-absolutely-nothing\/"}};</script><script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"eremedia"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ere.net/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.22' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.22"},"disqusIdentifier":"179537 https:\/\/www.ere.net\/?p=179537","disqusShortname":"eremedia","disqusTitle":"What\u2019s New and Fresh in the Candidate Experience? Absolutely Nothing","disqusUrl":"https:\/\/www.ere.net\/whats-new-and-fresh-in-the-candidate-experience-absolutely-nothing\/","postId":"179537"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ere.net/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.22' id='disqus_embed-js'></script>
<script type='text/javascript' id='leadin-script-loader-js-js-extra'>
/* <![CDATA[ */
var leadin_wordpress = {"userRole":"visitor","pageType":"post","leadinPluginVersion":"8.4.90"};
/* ]]> */
</script>
<script type='text/javascript' src='https://js.hs-scripts.com/7873053.js?integration=WordPress' async defer id='hs-script-loader'></script>
<script type='text/javascript' id='social_warfare_script-js-extra'>
/* <![CDATA[ */
var socialWarfare = {"addons":["pro"],"post_id":"179537","variables":{"emphasizeIcons":false,"powered_by_toggle":false,"affiliate_link":"https:\/\/warfareplugins.com"},"floatBeforeContent":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ere.net/wp-content/plugins/social-warfare/assets/js/script.min.js?ver=4.3.0' id='social_warfare_script-js'></script>
<script type='text/javascript' src='https://www.ere.net/wp-content/themes/parent-eremedia/assets/js/main.js?ver=1.1.1' id='p12a-main-js'></script>
<script type='text/javascript' src='https://www.ere.net/wp-includes/js/comment-reply.min.js?ver=5.9.3' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.ere.net/wp-content/plugins/wordpress-popup/inc/external/wpmu-lib/js/wpmu-ui.3.min.js?ver=5.9.3' id='wpmu-wpmu-ui-3-min-js-js'></script>
<script type='text/javascript' src='https://www.ere.net/wp-content/plugins/wordpress-popup/js/public.min.js?ver=5.9.3' id='wpmu-public-min-js-js'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.9.3' async='async' id='remote_sdk-js'></script>
<script type="text/javascript"> var swp_nonce = "84c7aba085";function parentIsEvil() { var html = null; try { var doc = top.location.pathname; } catch(err){ }; if(typeof doc === "undefined") { return true } else { return false }; }; if (parentIsEvil()) { top.location = self.location.href; };var url = "https://www.ere.net/whats-new-and-fresh-in-the-candidate-experience-absolutely-nothing/";if(url.indexOf("stfi.re") != -1) { var canonical = ""; var links = document.getElementsByTagName("link"); for (var i = 0; i < links.length; i ++) { if (links[i].getAttribute("rel") === "canonical") { canonical = links[i].getAttribute("href")}}; canonical = canonical.replace("?sfr=1", "");top.location = canonical; console.log(canonical);};var swpFloatBeforeContent = false; var swp_ajax_url = "https://www.ere.net/wp-admin/admin-ajax.php"; var swp_post_id = "179537";var swpClickTracking = false; swpPinIt={"enabled":false};</script></body>
</html>
